Front-end widgets are loading intermittently for some users

Incident Report for SiteVibes

Postmortem

SiteVibes experienced intermittent service issues stemming from a widespread Cloudflare outage. The disruption impacted network routing and edge processing, which caused intermittent failures across several SiteVibes services, including dashboard access, API calls, and email/SMS send operations.

Our internal systems remained fully operational, but Cloudflare’s degraded network paths created request failures for traffic passing through affected Cloudflare PoPs.

Impact

  • Dashboard: Some users experienced failed page loads or increased latency.
  • API Requests: A subset of API calls intermittently timed out.
  • Email & SMS Processing: Small delays for campaigns queued during the outage window.
  • Widgets (Reviews, Loyalty, Social Proof, UGC): In some cases, widgets failed to load or returned partial data depending on the user’s geographic routing.
  • Webhooks: A small number of inbound/outbound webhook requests required automatic retries.

No data loss occurred. All queued jobs successfully processed once Cloudflare restored service.

Root Cause

Cloudflare reported a global network incident affecting connectivity across multiple regions. This caused:

  • Packet loss on specific Cloudflare routes
  • Failed edge requests
  • Unreachable endpoints for customers routed through impacted PoPs

SiteVibes’ infrastructure itself did not fail—the issue arose entirely from Cloudflare’s external network layer.

Resolution

Once Cloudflare stabilized their network, all SiteVibes services returned to normal. We monitored all systems for an additional hour to confirm full recovery.

Posted Nov 21, 2025 - 14:33 CST

Resolved

This incident has been resolved.
Posted Nov 07, 2025 - 13:48 CST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 07, 2025 - 12:21 CST

Update

We are continuing to work on a fix for this issue.
Posted Nov 07, 2025 - 11:47 CST

Identified

The issue has been identified and a fix is being implemented.
Posted Nov 07, 2025 - 11:39 CST

Investigating

We are investigating the slow performance in widgets loading.
Posted Nov 07, 2025 - 10:45 CST
This incident affected: SiteVibes Loyalty, SiteVibes Reviews, SiteVibes Email Marketing, SiteVibes API, Social Proof & Trending Wall, and Visual Marketing & UGC.